'503' page error after form submission
Incident Report for Landingi
Resolved
This incident has been resolved.
Posted Nov 10, 2022 - 11:54 UTC
Identified
This issue affect only pages published on global landend with 'A' record. We are working on it.
Posted Nov 10, 2022 - 11:47 UTC
This incident affected: Landing Pages.