Issue with access to invoices
Incident Report for Landingi
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 07:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 01, 2021 - 07:45 UTC
Investigating
The "Invoices" tab (together with the option to download an invoice) and the option to change payment methods may not be available at the moment due to external provider problems.
Posted Oct 01, 2021 - 06:48 UTC
This incident affected: Application (new.landingi.com).