Some users might experience a delay or errors in landing page publishing and lead delivery
Incident Report for Landingi
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 12:25 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 13, 2024 - 22:47 UTC
Identified
This incident has been resolved.
Posted Mar 13, 2024 - 22:46 UTC
Investigating
We are currently investigating this issue.
Posted Mar 13, 2024 - 16:02 UTC
This incident affected: Application (new.landingi.com) and Editor (editor.landingi.com).