DDoS attack on landing pages
Incident Report for Landingi
Resolved
The issue was resolved
Posted Mar 25, 2021 - 21:09 UTC
Identified
We're currently under attack on Landing Pages and working on restoring the service as soon as possible
Posted Mar 25, 2021 - 20:34 UTC
This incident affected: Landing Pages.