DDoS attack on Landing Pages

Incident Report for Landingi

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 12:52 UTC

Investigating

We're currently under attack on Landing Pages and working on restoring performance as soon as possible
Posted Jul 07, 2025 - 11:04 UTC
This incident affected: Landing Pages.