Home page not responding
Incident Report for Landingi
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 19:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2021 - 19:40 UTC
Investigating
Our home page may temporarily stop responding. Landing pages and platform are fully available, login page might be accessed directly from this link: https://new.landingi.com/.
Posted Mar 10, 2021 - 19:33 UTC