Performance downgraded

Incident Report for Landingi

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 11:40 UTC

Investigating

You might experience issues trying to log into the platform or using application
Posted Sep 24, 2025 - 10:57 UTC
This incident affected: Application (app.landingi.com) and Editor (editor.landingi.com).