Downgraded performance

Incident Report for Landingi

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 15:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2025 - 15:44 UTC

Investigating

We are experiencing a heavier than usual load on our servers, due to a potential attack. There might be a delay in loading of your landing pages or default thank you pages.
Posted Feb 10, 2025 - 15:00 UTC
This incident affected: Landing Pages.