Service outage

Incident Report for Landingi

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 11:34 UTC

Identified

Some landing pages are not responding. You may consider pausing your paid campaigns.
Posted Jul 18, 2025 - 11:27 UTC
This incident affected: Landing Pages.