Decreased performance and landing page availability

Incident Report for Landingi

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 15:04 UTC

Monitoring

The functionality of services should now be back to normal. We are continuing to monitor the overall stability to ensure everything remains fully operational.
Problems was caused by recent problems with CloudFlare and AWS Cloud.
Posted Jun 02, 2026 - 14:51 UTC

Investigating

Due to technical issues application and some landing page elements may temporarily fail to work correctly. We are actively working to minimize the impact on our platform. We apologise for any inconvenience and will provide further updates as they become available.
Posted Jun 02, 2026 - 14:23 UTC
This incident affected: Landing Pages, Application (app.landingi.com), and Editor (editor.landingi.com).